Error in creating a basic TCP bridge

Apr 22, 2015 at 8:29 PM
I have a very simple project that needs to bridge two incoming TCP connections. I looked at some of the ini files and created the following:

[connection1]
name=connection1
type=incoming
port=42420
target=connection2

[connection2]
name=connection2
type=incoming
port=42421
target=connection1

When I try to execute it, I get the following error messages:

a, 15-04-22 15:19:29, start error_handle for process osi.production.tcp_bridge,
ver 1.0.5512.13368, process id 4792, tf changeset id 112626, built at 2015-02-03
07:24, osi.root.utils.dll.osi.root.utils.error_handle..cctor
e, 15-04-22 15:19:30, failed to create listener on 0000:0000:0000:0000:0000:0000
:0.0.0.0 with port 42420, osi.service.tcp.dll.osi.service.tcp.accepter.create_li
stener
w, 15-04-22 15:19:30, reference_count_event_comb_1.init failed, osi.root.procedu
re.dll.osi.root.procedure.reference_count_event_comb_1+_Closure$__114.Lambda$

205
e, 15-04-22 15:19:30, failed to create listener on 0000:0000:0000:0000:0000:0000
:0.0.0.0 with port 42421, osi.service.tcp.dll.osi.service.tcp.accepter.create_li
stener
w, 15-04-22 15:19:30, reference_count_event_comb_1.init failed, osi.root.procedu
re.dll.osi.root.procedure.reference_count_event_comb_1+_Closure$__114.Lambda$

205

This is a Windows XPSP3 machine and it has .NET 3.5 and 4.0 installed. start_redirect_3389_to_42420.cmd also fails with similar errors. I tried disabling the firewall with the same result. The only antivirus software running is AVG2011.

Do you have any ideas what's causing the problem?
Thanks!
-Stan
Sep 9, 2015 at 5:03 PM
Edited Sep 9, 2015 at 6:25 PM
Sorry for the late response, the error message just shows you cannot use IPv6 in Windows XP (which may be expected, since the IPv6 implementation in Windows XP is significantly different than Vista or higher.) I believe this issue should not impact the service for IPv4.